const regex = /\"([^\"]*)\":\s*('[^']*'|\"[^\"]*\"|[+\-]?\d+(?:.\d+)?)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\"([^\\"]*)\\":\\s*(\'[^\']*\'|\\"[^\\"]*\\"|[+\\-]?\\d+(?:.\\d+)?)', 'g')
const str = `define({
"key1": "some text: and more",
"KeyA": ["Elem1", "Elem2"]
key2 : 'some text ',
key3: ": more some text",
key4: 'some text:',
key5: 1998,
key6: +45.122,
key7: -33,
});`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}