// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\"([^\"]*)\":\s*('[^']*'|\"[^\"]*\"|[+\-]?\d+(?:.\d+)?)"#).unwrap();
let string = "define({
\"key1\": \"some text: and more\",
\"KeyA\": [\"Elem1\", \"Elem2\"]
key2 : 'some text ',
key3: \": more some text\",
key4: 'some text:',
key5: 1998,
key6: +45.122,
key7: -33,
});";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}