package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\"([^\"]*)\":\s*('[^']*'|\"[^\"]*\"|[+\-]?\d+(?:.\d+)?)`)
var str = `define({
"key1": "some text: and more",
"KeyA": ["Elem1", "Elem2"]
key2 : 'some text ',
key3: ": more some text",
key4: 'some text:',
key5: 1998,
key6: +45.122,
key7: -33,
});`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}