# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.+\sи\s(.+)$/$1/gm;t' <<< "9 часов назад
1 минута назад
________
день и 9 часов назад
неделю и день назад
3 недели и 3 дня назад
месяц и неделю назад
2 месяца и 3 недели"