import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.+\\sи\\s(.+)$";
final String string = "9 часов назад \n"
+ "1 минута назад\n"
+ "________\n"
+ "день и 9 часов назад\n"
+ "неделю и день назад\n"
+ "3 недели и 3 дня назад\n"
+ "месяц и неделю назад\n"
+ "2 месяца и 3 недели";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}