re = /^.+\sи\s(.+)$/m
str = '9 часов назад
1 минута назад
________
день и 9 часов назад
неделю и день назад
3 недели и 3 дня назад
месяц и неделю назад
2 месяца и 3 недели'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result