# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.+\sи\s(.+)$"
test_str = ("9 часов назад \n"
"1 минута назад\n"
"________\n"
"день и 9 часов назад\n"
"неделю и день назад\n"
"3 недели и 3 дня назад\n"
"месяц и неделю назад\n"
"2 месяца и 3 недели")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.