const regex = /^.+\sи\s(.+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.+\\sи\\s(.+)$', 'gm')
const str = `9 часов назад
1 минута назад
________
день и 9 часов назад
неделю и день назад
3 недели и 3 дня назад
месяц и неделю назад
2 месяца и 3 недели`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);