import Foundation
let pattern = #"^.+\sи\s(.+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
9 часов назад
1 минута назад
________
день и 9 часов назад
неделю и день назад
3 недели и 3 дня назад
месяц и неделю назад
2 месяца и 3 недели
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)