#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.+\sи\s(.+)$"
Local $sString = "9 часов назад " & @CRLF & _
"1 минута назад" & @CRLF & _
"________" & @CRLF & _
"день и 9 часов назад" & @CRLF & _
"неделю и день назад" & @CRLF & _
"3 недели и 3 дня назад" & @CRLF & _
"месяц и неделю назад" & @CRLF & _
"2 месяца и 3 недели"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)