use strict;
my $str = '9 часов назад
1 минута назад
________
день и 9 часов назад
неделю и день назад
3 недели и 3 дня назад
месяц и неделю назад
2 месяца и 3 недели';
my $regex = qr/^.+\sи\s(.+)$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";