import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^\"\\'\\/]*)[^\"\\']*";
final String string = "steve=\n"
+ "\"john\" \n"
+ "'leo' \n"
+ "sophie\n"
+ "\"john\n"
+ "eliott\"\n"
+ "'john\n"
+ "john'\n";
final String subst = "<span class=\"\">\\0</span>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}