import re
regex = re.compile(r"^([^\"\'\/]*)[^\"\']*")
test_str = ("steve=\n"
"\"john\" \n"
"'leo' \n"
"sophie\n"
"\"john\n"
"eliott\"\n"
"'john\n"
"john'\n")
subst = "<span class=\"\">\\0</span>"
result = regex.sub(subst, test_str)
if result:
print(result)