$re = '/^([^"\'\/]*)[^"\']*/';
$str = 'steve=
"john"
\'leo\'
sophie
"john
eliott"
\'john
john\'
';
$subst = "<span class=\"\">\0</span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;