re = /^([^"\'\/]*)[^"\']*/
str = 'steve=
"john"
\'leo\'
sophie
"john
eliott"
\'john
john\'
'
subst = '<span class="">\\0</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result