#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)color+=([\#]{1}|[\w\W]{1}|[\#A-Za-z0-9]{7,})"
Local $sString = "test[color=#663300]test[/color]vdfvd" & @CRLF & _
"test[color=#663300]test[/color]vdfvd" & @CRLF & _
"" & @CRLF & _
"[color=#]test[/color]" & @CRLF & _
"" & @CRLF & _
"[color=#]test[/color]" & @CRLF & _
"" & @CRLF & _
"test" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[color=#66330gdgf0]test[/color]" & @CRLF & _
"" & @CRLF & _
"[color=#66330gdgf0]test[/color]" & @CRLF & _
"" & @CRLF & _
"test" & @CRLF & _
"[color=]test[/color]" & @CRLF & _
"" & @CRLF & _
"[color=]test[/color]" & @CRLF & _
"" & @CRLF & _
"test" & @CRLF & _
"test" & @CRLF & _
"test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")