import Foundation
let pattern = ##"color+=([\#]{1}|[\w\W]{1}|[\#A-Za-z0-9]{7,})"##
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = ##"""
test[color=#663300]test[/color]vdfvd
test[color=#663300]test[/color]vdfvd
[color=#]test[/color]
[color=#]test[/color]
test
[color=#66330gdgf0]test[/color]
[color=#66330gdgf0]test[/color]
test
[color=]test[/color]
[color=]test[/color]
test
test
test
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)