package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)color+=([\#]{1}|[\w\W]{1}|[\#A-Za-z0-9]{7,})`)
var str = `test[color=#663300]test[/color]vdfvd
test[color=#663300]test[/color]vdfvd
[color=#]test[/color]
[color=#]test[/color]
test
[color=#66330gdgf0]test[/color]
[color=#66330gdgf0]test[/color]
test
[color=]test[/color]
[color=]test[/color]
test
test
test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}