import re
regex = re.compile(r"color+=([\#]{1}|[\w\W]{1}|[\#A-Za-z0-9]{7,})", flags=re.IGNORECASE)
test_str = ("test[color=#663300]test[/color]vdfvd\n"
"test[color=#663300]test[/color]vdfvd\n\n"
"[color=#]test[/color]\n\n"
"[color=#]test[/color]\n\n"
"test\n\n\n"
"[color=#66330gdgf0]test[/color]\n\n"
"[color=#66330gdgf0]test[/color]\n\n"
"test\n"
"[color=]test[/color]\n\n"
"[color=]test[/color]\n\n"
"test\n"
"test\n"
"test")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")