use strict;
my $str = 'test[color=#663300]test[/color]vdfvd
test[color=#663300]test[/color]vdfvd
[color=#]test[/color]
[color=#]test[/color]
test
[color=#66330gdgf0]test[/color]
[color=#66330gdgf0]test[/color]
test
[color=]test[/color]
[color=]test[/color]
test
test
test';
my $regex = qr/color+=([\#]{1}|[\w\W]{1}|[\#A-Za-z0-9]{7,})/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}