import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "color+=([\\#]{1}|[\\w\\W]{1}|[\\#A-Za-z0-9]{7,})";
final String string = "test[color=#663300]test[/color]vdfvd\n"
+ "test[color=#663300]test[/color]vdfvd\n\n"
+ "[color=#]test[/color]\n\n"
+ "[color=#]test[/color]\n\n"
+ "test\n\n\n"
+ "[color=#66330gdgf0]test[/color]\n\n"
+ "[color=#66330gdgf0]test[/color]\n\n"
+ "test\n"
+ "[color=]test[/color]\n\n"
+ "[color=]test[/color]\n\n"
+ "test\n"
+ "test\n"
+ "test";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}