using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"color+=([\#]{1}|[\w\W]{1}|[\#A-Za-z0-9]{7,})";
string input = @"test[color=#663300]test[/color]vdfvd
test[color=#663300]test[/color]vdfvd
[color=#]test[/color]
[color=#]test[/color]
test
[color=#66330gdgf0]test[/color]
[color=#66330gdgf0]test[/color]
test
[color=]test[/color]
[color=]test[/color]
test
test
test";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}