# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?m)^[^\S\r\n]*(\S+)[ \t]+(\S+)[ \t]+(\S+)/array($2, "$1", "$3"),/g;t' <<< " FOO 100 BOR
PAL 350 PIL
KIL 090 KUP"