using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^[^\S\r\n]*(\S+)[ \t]+(\S+)[ \t]+(\S+)";
string substitution = @"array($2, ""$1"", ""$3""),";
string input = @" FOO 100 BOR
PAL 350 PIL
KIL 090 KUP";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}