import Foundation
let pattern = #"(?m)^[^\S\r\n]*(\S+)[ \t]+(\S+)[ \t]+(\S+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
FOO 100 BOR
PAL 350 PIL
KIL 090 KUP
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"array($2, "$1", "$3"),"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)