// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^\S\r\n]*(\S+)[ \t]+(\S+)[ \t]+(\S+)").unwrap();
let string = " FOO 100 BOR
PAL 350 PIL
KIL 090 KUP";
let substitution = "array($2, \"$1\", \"$3\"),";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}