re = /(?m)^[^\S\r\n]*(\S+)[ \t]+(\S+)[ \t]+(\S+)/
str = ' FOO 100 BOR
PAL 350 PIL
KIL 090 KUP'
subst = 'array($2, "$1", "$3"),'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result