package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\S\r\n]*(\S+)[ \t]+(\S+)[ \t]+(\S+)`)
var str = ` FOO 100 BOR
PAL 350 PIL
KIL 090 KUP`
var substitution = "array($2, "$1", "$3"),"
fmt.Println(re.ReplaceAllString(str, substitution))
}