use strict;
my $str = ' FOO 100 BOR
PAL 350 PIL
KIL 090 KUP';
my $regex = qr/(?m)^[^\S\r\n]*(\S+)[ \t]+(\S+)[ \t]+(\S+)/p;
my $subst = 'array($2, "$1", "$3"),';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";