#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*\b(\d+)\b.*\b\1\b)\d+(?:,\d+)*$"
Local $sString = "123" & @CRLF & _
"123,1234" & @CRLF & _
"1,2,45,4567" & @CRLF & _
"" & @CRLF & _
"12,2343,12" & @CRLF & _
"" & @CRLF & _
",123,3444" & @CRLF & _
",3344" & @CRLF & _
"12,3,,344" & @CRLF & _
"23,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")