$re = '/^(?!.*\b(\d+)\b.*\b\1\b)\d+(?:,\d+)*$/m';
$str = '123
123,1234
1,2,45,4567
12,2343,12
,123,3444
,3344
12,3,,344
23,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);