const regex = /^(?!.*\b(\d+)\b.*\b\1\b)\d+(?:,\d+)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\b(\\d+)\\b.*\\b\\1\\b)\\d+(?:,\\d+)*$', 'gm')
const str = `123
123,1234
1,2,45,4567
12,2343,12
,123,3444
,3344
12,3,,344
23,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}