import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\b(\\d+)\\b.*\\b\\1\\b)\\d+(?:,\\d+)*$";
final String string = "123\n"
+ "123,1234\n"
+ "1,2,45,4567\n\n"
+ "12,2343,12\n\n"
+ ",123,3444\n"
+ ",3344\n"
+ "12,3,,344\n"
+ "23,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}