re = /^(?!.*\b(\d+)\b.*\b\1\b)\d+(?:,\d+)*$/m
str = '123
123,1234
1,2,45,4567
12,2343,12
,123,3444
,3344
12,3,,344
23,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end