import re
regex = re.compile(r"^(?!.*\b(\d+)\b.*\b\1\b)\d+(?:,\d+)*$", flags=re.MULTILINE)
test_str = ("123\n"
"123,1234\n"
"1,2,45,4567\n\n"
"12,2343,12\n\n"
",123,3444\n"
",3344\n"
"12,3,,344\n"
"23,")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")