import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!\\s|digit-)([0-9]{4})(?=-digit|\\.|\\?|\\s)";
final String string = " 3400-digit\n"
+ " 5000 5000 \n"
+ " 6700?\n"
+ "digit-9134?\n"
+ " 7500.\n\n"
+ "$5000 \n"
+ "£5550 \n"
+ "#5550 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}