re = /(?!\s|digit-)([0-9]{4})(?=-digit|\.|\?|\s)/m
str = ' 3400-digit
5000 5000
6700?
digit-9134?
7500.
$5000
£5550
#5550 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end