import re
regex = re.compile(r"(?!\s|digit-)([0-9]{4})(?=-digit|\.|\?|\s)", flags=re.MULTILINE)
test_str = (" 3400-digit\n"
" 5000 5000 \n"
" 6700?\n"
"digit-9134?\n"
" 7500.\n\n"
"$5000 \n"
"£5550 \n"
"#5550 ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")