const regex = /(?!\s|digit-)([0-9]{4})(?=-digit|\.|\?|\s)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!\\s|digit-)([0-9]{4})(?=-digit|\\.|\\?|\\s)', 'gm')
const str = ` 3400-digit
5000 5000
6700?
digit-9134?
7500.
\$5000
£5550
#5550 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}