$re = '/(?!\s|digit-)([0-9]{4})(?=-digit|\.|\?|\s)/m';
$str = ' 3400-digit
5000 5000
6700?
digit-9134?
7500.
$5000
£5550
#5550 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);