#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)CustRS|Customer Requirements|Customer Specification|02 - Regulatory|\*\\remote|"
Local $sString = "CustRS/" & @CRLF & _
"CustRS/remote" & @CRLF & _
"CustRS/Customer Requirements" & @CRLF & _
"CustRS/02 - Regulatory " & @CRLF & _
"CustRS/10 - remote" & @CRLF & _
"CustRS/Product_remote" & @CRLF & _
"CustRS/Customer Requirements/remote" & @CRLF & _
"CustRS/Product_remote/remote"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")