use strict;
my $str = 'CustRS/
CustRS/remote
CustRS/Customer Requirements
CustRS/02 - Regulatory
CustRS/10 - remote
CustRS/Product_remote
CustRS/Customer Requirements/remote
CustRS/Product_remote/remote';
my $regex = qr/CustRS|Customer Requirements|Customer Specification|02 - Regulatory|\*\\remote|/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}