const regex = /CustRS|Customer Requirements|Customer Specification|02 - Regulatory|\*\\remote|/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('CustRS|Customer Requirements|Customer Specification|02 - Regulatory|\\*\\\\remote|', 'gm')
const str = `CustRS/
CustRS/remote
CustRS/Customer Requirements
CustRS/02 - Regulatory
CustRS/10 - remote
CustRS/Product_remote
CustRS/Customer Requirements/remote
CustRS/Product_remote/remote`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}