import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "CustRS|Customer Requirements|Customer Specification|02 - Regulatory|\\*\\\\remote|";
final String string = "CustRS/\n"
+ "CustRS/remote\n"
+ "CustRS/Customer Requirements\n"
+ "CustRS/02 - Regulatory \n"
+ "CustRS/10 - remote\n"
+ "CustRS/Product_remote\n"
+ "CustRS/Customer Requirements/remote\n"
+ "CustRS/Product_remote/remote";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}