using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"CustRS|Customer Requirements|Customer Specification|02 - Regulatory|\*\\remote|";
string input = @"CustRS/
CustRS/remote
CustRS/Customer Requirements
CustRS/02 - Regulatory
CustRS/10 - remote
CustRS/Product_remote
CustRS/Customer Requirements/remote
CustRS/Product_remote/remote";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}