import re
regex = re.compile(r"CustRS|Customer Requirements|Customer Specification|02 - Regulatory|\*\\remote|", flags=re.MULTILINE)
test_str = ("CustRS/\n"
"CustRS/remote\n"
"CustRS/Customer Requirements\n"
"CustRS/02 - Regulatory \n"
"CustRS/10 - remote\n"
"CustRS/Product_remote\n"
"CustRS/Customer Requirements/remote\n"
"CustRS/Product_remote/remote")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")