# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((\D|^)0+(0|[1-9]+))/$2$3/g;t' <<< "0127.00.09.01
107.000.09.01
107.0.70.01
107.9.0.01
23.107.000.09
107.09.0.01
23.0.107.000
23.0.107.00
23.0.0127.01"