// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((\D|^)0+(0|[1-9]+))").unwrap();
let string = "0127.00.09.01
107.000.09.01
107.0.70.01
107.9.0.01
23.107.000.09
107.09.0.01
23.0.107.000
23.0.107.00
23.0.0127.01";
let substitution = "$2$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}