import re
regex = re.compile(r"((\D|^)0+(0|[1-9]+))")
test_str = ("0127.00.09.01\n"
"107.000.09.01\n"
"107.0.70.01\n"
"107.9.0.01\n"
"23.107.000.09\n"
"107.09.0.01\n"
"23.0.107.000\n"
"23.0.107.00\n"
"23.0.0127.01")
subst = "$2$3"
result = regex.sub(subst, test_str)
if result:
print(result)