package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((\D|^)0+(0|[1-9]+))`)
var str = `0127.00.09.01
107.000.09.01
107.0.70.01
107.9.0.01
23.107.000.09
107.09.0.01
23.0.107.000
23.0.107.00
23.0.0127.01`
var substitution = "$2$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}